]> git.rkrishnan.org Git - tahoe-lafs/tahoe-lafs.git/blobdiff - misc/feisty/debian/rules
rename bin/allmydata-tahoe to bin/tahoe. Closes #155.
[tahoe-lafs/tahoe-lafs.git] / misc / feisty / debian / rules
index 3d669daedbe9eb0ae9b88e5913136a5541964491..a7a6d1180ec819eb6c3680e0d80a9f6f4d270c9c 100644 (file)
@@ -9,9 +9,9 @@ include /usr/share/cdbs/1/class/python-distutils.mk
 
 STAGING_DIR=$(CURDIR)/debian/allmydata-tahoe
 
-# we overwrite the setuptools-generated /usr/bin/allmydata-tahoe with our
-# package's original version, because the setuptools form (using "entry
-# points") insists upon .egg-info -visible forms of dependent packages to be
+# we overwrite the setuptools-generated /usr/bin/tahoe with our package's
+# original version, because the setuptools form (using "entry points")
+# insists upon .egg-info -visible forms of dependent packages to be
 # installed. For a debian package, we rely upon the dependencies that are
 # declared in debian/control .
 #
@@ -23,7 +23,7 @@ STAGING_DIR=$(CURDIR)/debian/allmydata-tahoe
 install/allmydata-tahoe::
        mkdir -pm755 $(STAGING_DIR)
        python setup.py install --root=$(STAGING_DIR)
-       cp bin/allmydata-tahoe $(STAGING_DIR)/usr/bin/
+       cp bin/tahoe $(STAGING_DIR)/usr/bin/
 
        dh_pycentral