]> git.rkrishnan.org Git - functorrent.git/blobdiff - shell.nix
add quickcheck as a test dependency
[functorrent.git] / shell.nix
index cf892c6a0f9de8605c6b054a9def68e6ba8f40c2..401650300457f3507942a8b5ab1a944b82d506b4 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -13,7 +13,7 @@ with haskellPackages; cabal.mkDerivation (self: {
     base16Bytestring binary cryptohash HTTP networkUri parsec tasty
     tastyHunit
   ];
-  testDepends = [ doctest hlint tasty tastyHunit ];
+  testDepends = [ doctest hlint QuickCheck tasty tastyHunit ];
   meta = {
     description = "A Bit-torrent client";
     license = self.stdenv.lib.licenses.gpl3;