]> git.rkrishnan.org Git - functorrent.git/blobdiff - shell.nix
data: new test http tracker based torrent file
[functorrent.git] / shell.nix
index cf892c6a0f9de8605c6b054a9def68e6ba8f40c2..b3b0789721d813912c9894c84dce52dee8f07353 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,22 +1,12 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ haskellPackages ? (import <nixpkgs> {}).haskellPackages }:
-
-with haskellPackages; cabal.mkDerivation (self: {
-  pname = "functorrent";
-  version = "0.1.0.0";
-  src = "./.";
-  isLibrary = true;
-  isExecutable = true;
-  buildTools = [ cabalInstall ];
-  buildDepends = [
-    base16Bytestring binary cryptohash HTTP networkUri parsec tasty
-    tastyHunit
+let pkgs = (import <nixpkgs> {});
+    haskellPackages = pkgs.recurseIntoAttrs (pkgs.haskellPackages.override {
+        extension = self : super :
+        let callPackage = self.callPackage;
+        in {
+          thisPackage = haskellPackages.callPackage (import ./default.nix) {};
+        };});
+in pkgs.lib.overrideDerivation haskellPackages.thisPackage (old: {
+  buildInputs = old.buildInputs ++ [
+    haskellPackages.cabalInstall
   ];
-  testDepends = [ doctest hlint tasty tastyHunit ];
-  meta = {
-    description = "A Bit-torrent client";
-    license = self.stdenv.lib.licenses.gpl3;
-    platforms = self.ghc.meta.platforms;
-  };
 })