]> git.rkrishnan.org Git - tahoe-lafs/zfec.git/blobdiff - zfec/setup.py
setup: require setuptools >= 0.6c9 on Windows, but >= 0.6c6 on other platforms
[tahoe-lafs/zfec.git] / zfec / setup.py
index a2f64b3b82b81735ceaeb76393a6dce351b23690..938ca2a9b9df70036df47dbd2d61a5911acb9c2d 100755 (executable)
@@ -18,7 +18,16 @@ try:
 except ImportError:
     pass
 else:
-    use_setuptools(min_version='0.6c9', download_delay=0, to_dir=miscdeps)
+    if sys.platform.lower().startswith('win'):
+        # 0.6c7 on Windows had a problem with multiple overlapping dependencies
+        # on pyutil -- it would end up with the 'pyutil' key set in sys.modules
+        # but the actual code (and the temporary directory in the filesystem in
+        # which the code used to reside) gone, when it needed pyutil again
+        # later.
+        min_version='0.6c9'
+    else:
+        min_version='0.6c6'
+    use_setuptools(min_version=min_version, download_delay=0, to_dir=miscdeps)
 
 from setuptools import Extension, find_packages, setup