]> git.rkrishnan.org Git - tahoe-lafs/zfec.git/blobdiff - zfec/setup.py
setup: add setup_requires += stdeb if "sdist_dsc" appears in sys.argv
[tahoe-lafs/zfec.git] / zfec / setup.py
index ef123dcf69e03a7fd642e47d94c19c9d0fb2b13d..a2f64b3b82b81735ceaeb76393a6dce351b23690 100755 (executable)
@@ -123,6 +123,10 @@ setup_requires.append('darcsver >= 1.2.0')
 # http://pypi.python.org/pypi/setuptools_darcs
 setup_requires.append('setuptools_darcs >= 1.1.0')
 
+# stdeb is required to build Debian dsc files.
+if "sdist_dsc" in sys.argv:
+    setup_requires.append('stdeb')
+
 data_fnames=[ 'COPYING.GPL', 'changelog', 'COPYING.TGPPL.html', 'TODO', 'README.txt' ]
 
 # In case we are building for a .deb with stdeb's sdist_dsc command, we put the