]> git.rkrishnan.org Git - tahoe-lafs/zfec.git/blobdiff - zfec/setup.py
setup: setup_require setuptools_trial only if one of the argv is 'trial'
[tahoe-lafs/zfec.git] / zfec / setup.py
index a000c82af0348cf4cb2738fa1e68b47185c5f971..ac7c3139d0bbe38b152e1257bf889061c87ddbb6 100755 (executable)
@@ -120,7 +120,11 @@ if False:
     setup_requires.append('setuptools_darcs >= 1.1.0')
 
 
-setup_requires.append('setuptools_trial >= 0.5')
+# setuptools_trial is needed if you want "./setup.py trial" or
+# "./setup.py test" to execute the tests.
+# http://pypi.python.org/pypi/setuptools_trial
+if 'trial' in sys.argv[1:]:
+    setup_requires.extend(['setuptools_trial >= 0.5'])
 
 # trialcoverage is required if you want the "trial" unit test runner to have a
 # "--reporter=bwverbose-coverage" option which produces code-coverage results.