]> git.rkrishnan.org Git - tahoe-lafs/zfec.git/blobdiff - zfec/setup.py
docs: update docs and metadata
[tahoe-lafs/zfec.git] / zfec / setup.py
index c45b1448c3e2557269be7f6c5b842a5a93a32154..f3474d9cd54966f5f5f4ac2c1009a617805297f5 100755 (executable)
@@ -7,7 +7,7 @@
 #
 # This file is part of zfec.
 #
-# See README.txt for licensing information.
+# See README.rst for licensing information.
 
 import glob, os, re, sys
 
@@ -133,42 +133,30 @@ if "--reporter=bwverbose-coverage" in sys.argv:
 if "sdist_dsc" in sys.argv:
     setup_requires.append('stdeb')
 
-data_fnames=[ 'COPYING.GPL', 'changelog', 'COPYING.TGPPL.html', 'TODO', 'README.txt' ]
+data_fnames=[ 'COPYING.GPL', 'changelog', 'COPYING.TGPPL.html', 'TODO', 'README.rst' ]
 
 # In case we are building for a .deb with stdeb's sdist_dsc command, we put the
 # docs in "share/doc/$PKG".
 doc_loc = "share/doc/" + PKG
 data_files = [(doc_loc, data_fnames)]
 
-def _setup(test_suite):
-    setup(name=PKG,
-          version=verstr,
-          description='a fast erasure codec which can be used with the command-line, C, Python, or Haskell',
-          long_description='Fast, portable, programmable erasure coding a.k.a. "forward error correction": the generation of redundant blocks of information such that if some blocks are lost then the original data can be recovered from the remaining blocks.  The zfec package includes command-line tools, C API, Python API, and Haskell API',
-          author='Zooko O\'Whielacronx',
-          author_email='zooko@zooko.com',
-          url='http://allmydata.org/trac/'+PKG,
-          license='GNU GPL',
-          install_requires=["argparse >= 0.8", "pyutil >= 1.3.19"],
-          tests_require=tests_require,
-          packages=find_packages(),
-          include_package_data=True,
-          data_files=data_files,
-          setup_requires=setup_requires,
-          classifiers=trove_classifiers,
-          entry_points = { 'console_scripts': [ 'zfec = %s.cmdline_zfec:main' % PKG, 'zunfec = %s.cmdline_zunfec:main' % PKG ] },
-          ext_modules=[Extension(PKG+'._fec', [PKG+'/fec.c', PKG+'/_fecmodule.c',], extra_link_args=extra_link_args, extra_compile_args=extra_compile_args, undef_macros=undef_macros, define_macros=define_macros),],
-          test_suite=test_suite,
-          zip_safe=False, # I prefer unzipped for easier access.
-          )
-
-test_suite_name=PKG+".test"
-try:
-    _setup(test_suite=test_suite_name)
-except Exception, le:
-    # to work around a bug in Elisa v0.3.5
-    # https://bugs.launchpad.net/elisa/+bug/263697
-    if "test_suite must be a list" in str(le):
-        _setup(test_suite=[test_suite_name])
-    else:
-        raise
+setup(name=PKG,
+      version=verstr,
+      description='a fast erasure codec which can be used with the command-line, C, Python, or Haskell',
+      long_description = open('README.rst').read(),
+      author='Zooko O\'Whielacronx',
+      author_email='zooko@zooko.com',
+      url='http://tahoe-lafs.org/trac/'+PKG,
+      license='GNU GPL',
+      install_requires=["argparse >= 0.8", "pyutil >= 1.3.19"],
+      tests_require=tests_require,
+      packages=find_packages(),
+      include_package_data=True,
+      data_files=data_files,
+      setup_requires=setup_requires,
+      classifiers=trove_classifiers,
+      entry_points = { 'console_scripts': [ 'zfec = %s.cmdline_zfec:main' % PKG, 'zunfec = %s.cmdline_zunfec:main' % PKG ] },
+      ext_modules=[Extension(PKG+'._fec', [PKG+'/fec.c', PKG+'/_fecmodule.c',], extra_link_args=extra_link_args, extra_compile_args=extra_compile_args, undef_macros=undef_macros, define_macros=define_macros),],
+      test_suite=PKG+".test",
+      zip_safe=False, # I prefer unzipped for easier access.
+      )