]> git.rkrishnan.org Git - functorrent.git/blob - default.nix
refactoring: return type of tracker
[functorrent.git] / default.nix
1 # This file was auto-generated by cabal2nix. Please do NOT edit manually!
2
3 { cabal, base16Bytestring, binary, cryptohash, doctest, hlint, HTTP
4 , networkUri, parsec, QuickCheck, tasty, tastyHunit
5 , tastyQuickcheck, testFrameworkQuickcheck2
6 }:
7
8 cabal.mkDerivation (self: {
9   pname = "functorrent";
10   version = "0.1.0.0";
11   src = ./.;
12   isLibrary = true;
13   isExecutable = true;
14   buildDepends = [
15     base16Bytestring binary cryptohash HTTP networkUri parsec
16     QuickCheck tasty tastyHunit
17   ];
18   testDepends = [
19     doctest hlint QuickCheck tasty tastyHunit tastyQuickcheck
20     testFrameworkQuickcheck2
21   ];
22   meta = {
23     description = "A Bit-torrent client";
24     license = self.stdenv.lib.licenses.gpl3;
25     platforms = self.ghc.meta.platforms;
26   };
27 })