]> git.rkrishnan.org Git - functorrent.git/blob - shell.nix
cf892c6a0f9de8605c6b054a9def68e6ba8f40c2
[functorrent.git] / shell.nix
1 # This file was auto-generated by cabal2nix. Please do NOT edit manually!
2
3 { haskellPackages ? (import <nixpkgs> {}).haskellPackages }:
4
5 with haskellPackages; cabal.mkDerivation (self: {
6   pname = "functorrent";
7   version = "0.1.0.0";
8   src = "./.";
9   isLibrary = true;
10   isExecutable = true;
11   buildTools = [ cabalInstall ];
12   buildDepends = [
13     base16Bytestring binary cryptohash HTTP networkUri parsec tasty
14     tastyHunit
15   ];
16   testDepends = [ doctest hlint tasty tastyHunit ];
17   meta = {
18     description = "A Bit-torrent client";
19     license = self.stdenv.lib.licenses.gpl3;
20     platforms = self.ghc.meta.platforms;
21   };
22 })