]> git.rkrishnan.org Git - tahoe-lafs/tahoe-lafs.git/log
tahoe-lafs/tahoe-lafs.git
8 years agoWIP. Sigh, I no longer remember what I was trying to do here. 2477.refactor-all-the-things.0.wip
Daira Hopwood [Wed, 19 Aug 2015 13:40:16 +0000 (14:40 +0100)]
WIP. Sigh, I no longer remember what I was trying to do here.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoMerge pull request #184 from vu3rdd/2477.refactor-all-the-things.0
Daira Hopwood [Wed, 12 Aug 2015 13:11:58 +0000 (14:11 +0100)]
Merge pull request #184 from vu3rdd/2477.refactor-all-the-things.0

test for get_pathinfo()

8 years agotest_get_pathinfo: testdir is unnecessary 182/head 183/head 184/head
Ramakrishnan Muthukrishnan [Wed, 12 Aug 2015 09:47:27 +0000 (15:17 +0530)]
test_get_pathinfo: testdir is unnecessary

Use basedir itself, instead of creating another directory inside basedir.

8 years agotest_get_pathinfo: rename the identifier d to testdir
Ramakrishnan Muthukrishnan [Wed, 12 Aug 2015 09:02:40 +0000 (14:32 +0530)]
test_get_pathinfo: rename the identifier d to testdir

d, by convention, is used for the Twisted Deferred objects.

8 years agoadd more tests for get_pathinfo()
Ramakrishnan Muthukrishnan [Wed, 12 Aug 2015 08:56:52 +0000 (14:26 +0530)]
add more tests for get_pathinfo()

When operating on a file, test if the "file" is not a directory
or a symlink. Likewise for directory and symlink.

8 years agoAdd test for get_pathinfo()
Ramakrishnan Muthukrishnan [Wed, 12 Aug 2015 08:43:13 +0000 (14:13 +0530)]
Add test for get_pathinfo()

8 years agoUse get_pathinfo instead of separate os.path.{is*,exists} calls.
Daira Hopwood [Tue, 11 Aug 2015 16:02:53 +0000 (17:02 +0100)]
Use get_pathinfo instead of separate os.path.{is*,exists} calls.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoExtend get_pathinfo to add size, ctime and mtime.
Daira Hopwood [Tue, 11 Aug 2015 15:02:25 +0000 (16:02 +0100)]
Extend get_pathinfo to add size, ctime and mtime.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRemove an unnecessary precondition and an incorrect comment.
Daira Hopwood [Tue, 11 Aug 2015 14:46:31 +0000 (15:46 +0100)]
Remove an unnecessary precondition and an incorrect comment.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoAdd fileutil.get_pathinfo function.
Daira Hopwood [Tue, 11 Aug 2015 14:43:01 +0000 (15:43 +0100)]
Add fileutil.get_pathinfo function.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoExtract get_metadata and get_filenode to methods of Uploader.
Daira Hopwood [Tue, 11 Aug 2015 14:21:10 +0000 (15:21 +0100)]
Extract get_metadata and get_filenode to methods of Uploader.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoProcessing symlinks and special files should not be an error.
Daira Hopwood [Tue, 11 Aug 2015 14:19:05 +0000 (15:19 +0100)]
Processing symlinks and special files should not be an error.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRefactor uploader by inlining _add_file into _process._maybe_upload.
Daira Hopwood [Tue, 11 Aug 2015 14:17:16 +0000 (15:17 +0100)]
Refactor uploader by inlining _add_file into _process._maybe_upload.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRefactor uploader by inlining _add_file into _process._maybe_upload.
Daira Hopwood [Tue, 11 Aug 2015 14:09:56 +0000 (15:09 +0100)]
Refactor uploader by inlining _add_file into _process._maybe_upload.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRefactor uploader by extracting _process_child to a top-level method.
Daira Hopwood [Tue, 11 Aug 2015 14:06:27 +0000 (15:06 +0100)]
Refactor uploader by extracting _process_child to a top-level method.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoSwap two checks to clarify which is failing.
Daira Hopwood [Tue, 11 Aug 2015 14:04:36 +0000 (15:04 +0100)]
Swap two checks to clarify which is failing.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agofix code that adds version number of deleted file to magic-folder db
David Stainton [Fri, 31 Jul 2015 22:55:15 +0000 (15:55 -0700)]
fix code that adds version number of deleted file to magic-folder db

8 years agoenable version checking tests - currently a righteous fail
David Stainton [Fri, 31 Jul 2015 22:08:35 +0000 (15:08 -0700)]
enable version checking tests - currently a righteous fail

8 years agomake various changes - work in progress
David Stainton [Fri, 31 Jul 2015 22:06:12 +0000 (15:06 -0700)]
make various changes - work in progress

8 years agoadd version checking to alice bob test
David Stainton [Fri, 31 Jul 2015 18:09:30 +0000 (11:09 -0700)]
add version checking to alice bob test

8 years agoUpdate magic-folder db after download
David Stainton [Fri, 31 Jul 2015 17:51:19 +0000 (10:51 -0700)]
Update magic-folder db after download

8 years agoAdd final download to alice bob test
David Stainton [Thu, 30 Jul 2015 21:13:39 +0000 (14:13 -0700)]
Add final download to alice bob test

- that is to say after alice deletes the file she rewrites it
and this causes bob to download this latest version

8 years agoRemove old unused append to deque function from downloader
David Stainton [Thu, 30 Jul 2015 20:57:29 +0000 (13:57 -0700)]
Remove old unused append to deque function from downloader

8 years agoWIP to unify queue processing between uploader and downloader.
Daira Hopwood [Thu, 30 Jul 2015 17:52:05 +0000 (18:52 +0100)]
WIP to unify queue processing between uploader and downloader.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRepair tests.
Daira Hopwood [Thu, 30 Jul 2015 17:12:50 +0000 (18:12 +0100)]
Repair tests.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoMove uploader's _append_to_deque and _turn_deque to QueueMixin.
Daira Hopwood [Thu, 30 Jul 2015 17:04:44 +0000 (18:04 +0100)]
Move uploader's _append_to_deque and _turn_deque to QueueMixin.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoMake sure that counter names and log messages include "uploader" or "downloader".
Daira Hopwood [Thu, 30 Jul 2015 17:04:13 +0000 (18:04 +0100)]
Make sure that counter names and log messages include "uploader" or "downloader".

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoTrivial fix.
Daira Hopwood [Thu, 30 Jul 2015 15:24:57 +0000 (16:24 +0100)]
Trivial fix.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoremove debugging print statements
David Stainton [Wed, 29 Jul 2015 00:52:27 +0000 (17:52 -0700)]
remove debugging print statements

8 years agoFix alice bob test
David Stainton [Wed, 29 Jul 2015 00:46:46 +0000 (17:46 -0700)]
Fix alice bob test

8 years agoTeach downloader to stop when told to stop
David Stainton [Wed, 29 Jul 2015 00:02:51 +0000 (17:02 -0700)]
Teach downloader to stop when told to stop

8 years agoAdd logic to only add object to download queue when appropriate
David Stainton [Tue, 28 Jul 2015 18:09:35 +0000 (11:09 -0700)]
Add logic to only add object to download queue when appropriate

8 years agowip
David Stainton [Tue, 28 Jul 2015 00:00:39 +0000 (17:00 -0700)]
wip

8 years agoTry to fix some tests - WIP.
Daira Hopwood [Mon, 27 Jul 2015 16:51:40 +0000 (17:51 +0100)]
Try to fix some tests - WIP.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRename and refactor path variables to be more consistent.
Daira Hopwood [Mon, 27 Jul 2015 16:51:25 +0000 (17:51 +0100)]
Rename and refactor path variables to be more consistent.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoWIP - fix some bugs
David Stainton [Fri, 24 Jul 2015 22:12:57 +0000 (15:12 -0700)]
WIP - fix some bugs

8 years agoRefactor MagicFolder into Uploader and Downloader classes (WIP). refs ticket:2477
Daira Hopwood [Thu, 23 Jul 2015 23:27:26 +0000 (00:27 +0100)]
Refactor MagicFolder into Uploader and Downloader classes (WIP). refs ticket:2477

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoSimplify and document the type of MagicFolder._download_scan_batch. 1710.test-alice-and-bob.3
Daira Hopwood [Thu, 23 Jul 2015 22:15:24 +0000 (23:15 +0100)]
Simplify and document the type of MagicFolder._download_scan_batch.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRemove redundant call to abspath_expanduser_unicode.
Daira Hopwood [Thu, 23 Jul 2015 21:53:16 +0000 (22:53 +0100)]
Remove redundant call to abspath_expanduser_unicode.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoReduce code duplication and make sure errors from delegate commands are output.
Daira Hopwood [Mon, 20 Jul 2015 22:46:03 +0000 (23:46 +0100)]
Reduce code duplication and make sure errors from delegate commands are output.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoChange INVITE_SEPARATOR to '+'.
Daira Hopwood [Mon, 20 Jul 2015 22:03:02 +0000 (23:03 +0100)]
Change INVITE_SEPARATOR to '+'.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRename MagicFolderCLITestMixin to MagicFolderTestMixin.
Daira Hopwood [Mon, 20 Jul 2015 22:01:44 +0000 (23:01 +0100)]
Rename MagicFolderCLITestMixin to MagicFolderTestMixin.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoFix tests.
Daira Hopwood [Mon, 20 Jul 2015 17:13:08 +0000 (18:13 +0100)]
Fix tests.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoAdd checks (that currently fail) for version in local db.
Daira Hopwood [Mon, 20 Jul 2015 16:31:39 +0000 (17:31 +0100)]
Add checks (that currently fail) for version in local db.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoUse relative paths in magic folder db.
Daira Hopwood [Mon, 20 Jul 2015 16:30:56 +0000 (17:30 +0100)]
Use relative paths in magic folder db.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoWIP
Daira Hopwood [Mon, 20 Jul 2015 16:27:57 +0000 (17:27 +0100)]
WIP

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoFix some pyflakes errors and warnings.
Daira Hopwood [Thu, 16 Jul 2015 17:41:44 +0000 (18:41 +0100)]
Fix some pyflakes errors and warnings.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoRepair backupdb.
Daira Hopwood [Thu, 16 Jul 2015 16:55:02 +0000 (17:55 +0100)]
Repair backupdb.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agofix bug in test_errors and add test
David Stainton [Wed, 15 Jul 2015 23:54:26 +0000 (16:54 -0700)]
fix bug in test_errors and add test

- test that we report the correct error when
a write cap is passed as a collective dircap

8 years agoadd kw arg to _get_count for tests
David Stainton [Wed, 15 Jul 2015 23:16:33 +0000 (16:16 -0700)]
add kw arg to _get_count for tests

8 years agomake test_magic_folder use non-ascii chars in nickname
David Stainton [Wed, 15 Jul 2015 22:43:53 +0000 (15:43 -0700)]
make test_magic_folder use non-ascii chars in nickname

8 years agoMake alice bob test use non-ascii chars in nicknames
David Stainton [Wed, 15 Jul 2015 22:37:40 +0000 (15:37 -0700)]
Make alice bob test use non-ascii chars in nicknames

8 years agoadd comments and blank lines to make setup_alice_and_bob more readable
David Stainton [Wed, 15 Jul 2015 22:33:33 +0000 (15:33 -0700)]
add comments and blank lines to make setup_alice_and_bob more readable

8 years agorename to do_invite and do_join for tests
David Stainton [Wed, 15 Jul 2015 22:29:52 +0000 (15:29 -0700)]
rename to do_invite and do_join for tests

8 years agorename to do_create_magic_folder for tests
David Stainton [Wed, 15 Jul 2015 22:23:09 +0000 (15:23 -0700)]
rename to do_create_magic_folder for tests

8 years agorevert previous additional blank line
David Stainton [Wed, 15 Jul 2015 22:16:52 +0000 (15:16 -0700)]
revert previous additional blank line

8 years agowrap long import line
David Stainton [Wed, 15 Jul 2015 22:15:33 +0000 (15:15 -0700)]
wrap long import line

8 years agowrap long line and spell magic folder without hyphen
David Stainton [Wed, 15 Jul 2015 22:14:18 +0000 (15:14 -0700)]
wrap long line and spell magic folder without hyphen

8 years agoSpell magic folder without the hyphen
David Stainton [Wed, 15 Jul 2015 22:11:26 +0000 (15:11 -0700)]
Spell magic folder without the hyphen

8 years agowrap long line
David Stainton [Wed, 15 Jul 2015 22:09:40 +0000 (15:09 -0700)]
wrap long line

8 years agoreplace bare asserts with usage error message
David Stainton [Wed, 15 Jul 2015 22:07:24 +0000 (15:07 -0700)]
replace bare asserts with usage error message

8 years agoget rid of another diminish hack and force alias args to end with ':'
David Stainton [Wed, 15 Jul 2015 21:22:15 +0000 (14:22 -0700)]
get rid of another diminish hack and force alias args to end with ':'

8 years agoget rid of terrible diminish cap hack
David Stainton [Wed, 15 Jul 2015 20:57:58 +0000 (13:57 -0700)]
get rid of terrible diminish cap hack

8 years agominor corrections
David Stainton [Wed, 15 Jul 2015 19:35:10 +0000 (12:35 -0700)]
minor corrections

8 years agoslightly better error message
David Stainton [Wed, 15 Jul 2015 19:32:53 +0000 (12:32 -0700)]
slightly better error message

8 years agochange spelling module variable INVITE_SEPARATOR
David Stainton [Wed, 15 Jul 2015 19:30:05 +0000 (12:30 -0700)]
change spelling module variable INVITE_SEPARATOR

8 years agodon't double increment version
David Stainton [Wed, 15 Jul 2015 19:24:00 +0000 (12:24 -0700)]
don't double increment version

8 years agostart with version 0
David Stainton [Wed, 15 Jul 2015 19:21:54 +0000 (12:21 -0700)]
start with version 0

8 years agosimplify _db_file_is_uploaded
David Stainton [Wed, 15 Jul 2015 19:19:08 +0000 (12:19 -0700)]
simplify _db_file_is_uploaded

8 years agobetter handle download failures
David Stainton [Wed, 15 Jul 2015 19:18:05 +0000 (12:18 -0700)]
better handle download failures

8 years agoremove superfluous plus sign
David Stainton [Wed, 15 Jul 2015 19:15:25 +0000 (12:15 -0700)]
remove superfluous plus sign

8 years agofix remote scan procedure
David Stainton [Wed, 15 Jul 2015 19:14:12 +0000 (12:14 -0700)]
fix remote scan procedure

8 years agoreplace calls to filter with list comprehension
David Stainton [Tue, 14 Jul 2015 23:43:49 +0000 (16:43 -0700)]
replace calls to filter with list comprehension

8 years agosimplify _should_download helper method
David Stainton [Tue, 14 Jul 2015 23:41:16 +0000 (16:41 -0700)]
simplify _should_download helper method

8 years agorename ignore count to upload ignore count
David Stainton [Tue, 14 Jul 2015 23:39:26 +0000 (16:39 -0700)]
rename ignore count to upload ignore count

8 years agoremove superfluous constructor which the parent class already has
David Stainton [Tue, 14 Jul 2015 23:36:11 +0000 (16:36 -0700)]
remove superfluous constructor which the parent class already has

8 years agoMake backupdb schema evolution more visible
David Stainton [Tue, 14 Jul 2015 23:34:27 +0000 (16:34 -0700)]
Make backupdb schema evolution more visible

8 years agoalice bob test alice rewrite file
David Stainton [Tue, 14 Jul 2015 21:54:09 +0000 (14:54 -0700)]
alice bob test alice rewrite file

8 years agounlink old version of file from remote tahoe upload dirnode
David Stainton [Tue, 14 Jul 2015 20:29:17 +0000 (13:29 -0700)]
unlink old version of file from remote tahoe upload dirnode

8 years agofor local fs scan compare local version with remote
David Stainton [Tue, 14 Jul 2015 10:58:35 +0000 (03:58 -0700)]
for local fs scan compare local version with remote

8 years agoFix test_errors to check for exception message associated with
David Stainton [Mon, 13 Jul 2015 19:59:31 +0000 (12:59 -0700)]
Fix test_errors to check for exception message associated with
an invalid collective dircap.

8 years agoRemove workaround for collective_dircap and repair some tests.
Daira Hopwood [Mon, 13 Jul 2015 17:08:45 +0000 (18:08 +0100)]
Remove workaround for collective_dircap and repair some tests.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoEliminate near-duplicate code in CLITestMixin.
Daira Hopwood [Mon, 13 Jul 2015 17:07:52 +0000 (18:07 +0100)]
Eliminate near-duplicate code in CLITestMixin.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoFix test_create_magic_folder_service (was test_create_magic_folder).
Daira Hopwood [Mon, 20 Jul 2015 23:48:00 +0000 (00:48 +0100)]
Fix test_create_magic_folder_service (was test_create_magic_folder).

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoAdd missing Deferred creation.
Daira Hopwood [Thu, 9 Jul 2015 22:40:05 +0000 (23:40 +0100)]
Add missing Deferred creation.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agofix references to notifier
David Stainton [Wed, 8 Jul 2015 20:13:49 +0000 (13:13 -0700)]
fix references to notifier

8 years agovarious pyflakes fixes
David Stainton [Wed, 8 Jul 2015 17:09:15 +0000 (10:09 -0700)]
various pyflakes fixes

8 years agoAdd ready method to MockMagicFolder to partially fix a test.
Daira Hopwood [Mon, 20 Jul 2015 23:29:14 +0000 (00:29 +0100)]
Add ready method to MockMagicFolder to partially fix a test.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoFixes to Magic Folder client initialization.
Daira Hopwood [Mon, 6 Jul 2015 23:34:17 +0000 (00:34 +0100)]
Fixes to Magic Folder client initialization.

Signed-off-by: Daira Hopwood <daira@jacaranda.org>
8 years agoremove some superfluous print statements
David Stainton [Mon, 6 Jul 2015 20:11:18 +0000 (13:11 -0700)]
remove some superfluous print statements

8 years agoFix Alice Bob mock test
David Stainton [Mon, 6 Jul 2015 20:10:20 +0000 (13:10 -0700)]
Fix Alice Bob mock test

8 years agofix test_persistence
David Stainton [Fri, 3 Jul 2015 02:52:21 +0000 (19:52 -0700)]
fix test_persistence

8 years agofix some tests
David Stainton [Fri, 3 Jul 2015 01:14:24 +0000 (18:14 -0700)]
fix some tests

8 years agoFix version deletion propagation and test
David Stainton [Thu, 2 Jul 2015 22:50:49 +0000 (15:50 -0700)]
Fix version deletion propagation and test

8 years agoAdd version to magic folder db schema
David Stainton [Thu, 2 Jul 2015 18:49:13 +0000 (11:49 -0700)]
Add version to magic folder db schema

- also update handling file addition and deletion events
to utilize local and remote version numbers in the uploader...

^ untested so far althought he basic Alice + Bob test continues to pass

8 years agoAdd rough naive downloader + remote scan
David Stainton [Thu, 2 Jul 2015 04:11:05 +0000 (21:11 -0700)]
Add rough naive downloader + remote scan

- makes the basic naive Alice + Bob unit test pass
-  `_should_download` is currently a stub function and
should be implemented
- handling of local+remote file versions is currently faked...
and should be implemented

8 years agoRename deque to upload deque
David Stainton [Wed, 1 Jul 2015 18:01:55 +0000 (11:01 -0700)]
Rename deque to upload deque

here we also rename the pending deque set
to pending upload deque..

8 years agoadd partial remote scan implementation
David Stainton [Wed, 1 Jul 2015 02:38:19 +0000 (19:38 -0700)]
add partial remote scan implementation

8 years agoAdd magic-folder download callback
David Stainton [Wed, 1 Jul 2015 00:33:37 +0000 (17:33 -0700)]
Add magic-folder download callback

8 years agoAdd test for Bob download callback
David Stainton [Tue, 30 Jun 2015 23:03:28 +0000 (16:03 -0700)]
Add test for Bob download callback